
 

 

Google Docs is a free web-based office suite that allows you to store documents online 
so you can access them from any computer with an internet connection.  With Google 
Docs you can share a document with other people so that everyone can work on it at 
the same time.  You can even track revisions to see the edits made by everyone who 
has been invited to work on the document.  Google Docs supports many of the features 
of stand-alone word processing and spreadsheet programs, including the ability to add 
images, tables, and more.  To get started with Google Docs, all you need is a free Goo-
gle account.   

The Interface
Once you log in to Google Docs you will 
see a file manager interface.  Folders will 
be listed on the left side and documents 
on the right.  The blue toolbar at the top 
contains the buttons you will use to work 
with folders and documents. 

The folders list on the left contains a 
number of folders automatically created 
by Google Docs.
• Created by me: shows all documents 

you’ve created on Google Docs.
• Starred: shows any documents with a 

star assigned to them.  To assign a star 
to a document, click on the Star icon to 
the left of its name in the document list.

• Trash: shows documents you’ve de-
leted.  

- To delete a document, check the 
box next to its name and click on 
Delete on the toolbar.  

- To empty the trash, select the Trash 
folder on the folder list and then click 
on Empty trash on the toolbar.  

- To move documents out of the trash, 
select the Trash folder, check the 
box next to the documents you want 
to move out of the trash, and click 
on Undelete in the navigation bar.

 
The next section of the folder list shows 
all the folders created by you.  To create 
a new folder:
1. Choose New > Folder from the navi-

gation bar.
2. Enter a folder name.
3. Click on Add description/status to dis-

play a text field where you can enter a 
brief description or a note about the 
document’s status (Drat, etc.).

To delete a folder after you’ve created it, 
choose the folder in the folder list and 
then click on Delete in the toolbar.  To re-
name a folder, choose it in the folder list 
and click on Rename in the toolbar.

To place documents in a folder:
1. Select the documents by checking the 

boxes next to their names.
2. Click on Move to in the toolbar.
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3. Click on the name of the folder where 
you want to place the documents.

4. Click on Move to folder.

To move documents out of a folder:
1. Select the folder on the folder list.
2. On the right side, check the box next 

to the name of each document you 
want to move out of the folder.

3. Click on Move to in the toolbar.
4. Choose Remove from current folder.
5. Click on the Remove from current 

folder button.

The bottom section of the folder list al-
lows you to view your documents by type.
 

You can also view a list of people you’ve 
shared documents with along with the 
number of documents you’re sharing with 
each person.

Creating a New Document
There are two ways to create a new 
document in Google Docs: 
1. To create it from scratch in Google 

Docs, click on New on the toolbar and 
select Document or Spreadsheet.  
The new document or spreadsheet 
will open in a separate window.

2. To upload a document you’ve already 
created with another program (such 
as Microsoft Word, Excel or Power-
Point), click on Upload in the toolbar. 
Click on Browse and locate the file 
you want to upload. Enter a name for 
it and click on Upload File. 

To edit a document from the Google Docs 
file manager, click on its name in the 
documents list.  The document will open 

in a separate window.

Google Docs saves your open document 
at regular intervals.  You can also save a 
document by clicking on the Save or 
Save and close buttons.  Click on Discard 
changes to close your document without 
saving changes.

Google Docs
Formatting
Once you type some text into your new 
document, you can select it and use the 
buttons in the toolbar to format it:
• Make text bold
• Change text to italics
• Underline text
• Choose the font
• Change the text size

The Style drop-down menu has additional 
formatting options, such as superscript, 
subscript, and strikeout.  To create head-
ings, select the text you want for the 
heading and choose one of the three 
heading types in the Style drop-down 
menu.

To remove all formatting from the se-
lected text, click on the Remove Format-
ting button.

Editing
On the left size of the toolbar are the edit-
ing buttons, which you can use to copy 
and paste text:
• Undo last change
• Redo last change
• Cut
• Copy
• Paste

Alignment and Spacing
To change how text is aligned, click on 
one of the align buttons in the toolbar:
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To justify text, choose Style > Justify after 
you’ve selected the text.

To change the line spacing, choose Style 
> Page Spacing to bring up the Docu-
ment Settings window, then choose a dif-
ferent setting from the line-spacing drop-
down menu (Normal, Single, 1.5, Double, 
or Triple).  

Lists and Indentation
To create a list:
1. Place the cursor where you want the 

list to start.
2. Click on one of the list type buttons in 

the toolbar (numbered or bulleted).
3. Press Enter or Return after you’ve 

added an item to add the next one in 
the list.  To go to the next line without 
adding a new item, hold down the 
Shift key and press Enter or Return.

4. To end the list, click on the list type 
button in the toolbar again.

To indent a line of text, place your cursor 
at the beginning of the line of text and 
click on the Indent More button in the 
toolbar (click on Indent Less to undo the 
indentation).  To create a blockquote (in-
dented on both sides) select a block of 
text and click on the Quote button. 

Bookmarks and Links 
Bookmarks are markers that can be used 
to navigate on long documents.  To cre-
ate a new bookmark:
1. Place your cursor where you want to 

insert the bookmark.
2. Click on the Insert tab in the toolbar 

and choose Bookmark.
3. Enter a name for the bookmark.
4. Click on OK.

You can then create links at the top of 
your document that will take you to each 
bookmark.

To add a link:
1. Select the text you wan to make into a 

link.
2. Click on the link button in the toolbar.
3. Choose a link type: 
• URL: enter the address of a website in 

the URL field.  
• Document: choose another document in 

Google Docs from the pulldown menu.
• Bookmark: choose a bookmark from the 

pulldown menu. 
• E-mail address: enter the email address 

in the E-mail to: field.

Images
To add an image to your document:
1. Click on the Insert tab in the toolbar 

and choose Image.
2. Choose whether you want to use a 

computer stored on your computer or 
to use the URL of an image that’s al-
ready online.

3. Click on Browse to locate an image on 
your computer, or paste the URL of 
the image if it’s already online.

4. Click on the plus sign next to More 
image options to change the align-
ment and wrapping.  You can also re-
size your image by choosing a preset 
from the Size pulldown menu.

5. Click on OK. 

You can use the handles that appear 
when you click on an image to resize it.  
You can also drag and drop the image to 
change its location in the document.

Tables
To add a table:
1. Place your cursor where you want to 

add the table.
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2. Click on the Insert tab and choose Ta-
ble.

3. Enter the number of rows and col-
umns for your table.

4. Choose a width and height.
5. Set other options, such as back-

ground color, padding, spacing, and 
whether a border is displayed or not 
and the color of that border.

6. Click on Insert.
7. To add additional rows or columns, 

click inside a cell and use the controls 
on the cell’s edge.  The arrow deter-
mines where the cell or column will be 
added (above or below).  Click on the 
X to delete the current column or row.

8. You can use the handles to resize the 
table.

9. To delete the table, right-click and 
choose Delete table.

Exporting and Printing
Google Docs allows you to download 
your document to your computer using a 
number of formats (choose File > Export 
as):
• HTML (saves your document in a zip 

file that includes a web page and a 
folder with any images used in the 
page).

• Word or OpenOffice
• PDF
• Text (exports a plain text version).

You don’t have to open a document to 
export it.  To export documents from the 
file manager, check the box next to their 
names, then click on More actions in the 
toolbar and choose Save as and the for-
mat you want to save the documents to.

To print your document, click on the Print 
button above the toolbar or choose File > 
Print.  This will bring up the print dialog 
box where you can set options such as 
the number of pages, etc.  Click on Print 

or OK to print your document.

Publishing
You can publish your documents and 
Google Docs will create a unique URL 
you can share with others so they can 
view it online.

To publish an open document:
1. Click on the Publish tab above the 

toolbar.
2. Click on Publish document.
3. Right-click on the URL provided by 

Google Docs and copy and paste it 
into an email or use it to create a link 
on a web page.

4. To publish a document to a blog (a 
quick way to post a blog entry), click 
on Post to blog.  You will be asked to 
provide your Blog information (blog 
type, user name, and password) the 
first time you try to post to your blog 
from Google Docs.

To publish a document from the file man-
ager, select the document and then 
choose Publish by clicking on the More 
actions button in the toolbar.

Sharing
You can invite other people to collaborate 
on the same document.

To share an open document for collabora-
tion:
1. Click on the Share tab above the tool-

bar.
2. Select whether you want to invite the 

other people as collaborators or view-
ers (they will be able to access the 
document, but not change it).

3. Enter the email addresses of every-
one you want to invite, separated by a 
comma.
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4. Set Advanced permissions at the bot-
tom (you can allow the people you in-
vite to in turn invite other people they 
know, or you can allow the use of 
mailing lists - everyone must have a 
Google account) .

5. Click on Invite collaborators.
6. When the email window pops up, en-

ter a Subject and Message, then click 
on Send.

Revisions
Google Docs automatically tracks the 
changes made to your document by eve-
ryone who works on it.

To view a list of all revisions made on a 
document, click on the Revisions tab.  
You should see a list of revisions, each 
with a sequential number, the time when 
it was last edited, who did the edit,  and a 
summary of the changes.  

To view an individual revision, click on the 
link for it.  This will show you what your 
document looked like when the revision 
was saved.  If you want to save the revi-
sion as the latest version of your docu-
ment, click on Revert to this one. 

You can keep track of the revisions on 
your documents using RSS feeds.  To 
view the RSS feed for a document, click 
on the Share tab and then click on the 
View RSS feed link on the right.  The 
RSS feed will be displayed in your web 
browser.  You can copy the URL and use 
it to subscribe to the feed using a service 
such as Bloglines.

Google Spreadsheets
Formatting Cells
Google Spreadsheets includes many of 
the same formatting options as Google 
Docs.  There are a few options that are 
specific to working with a spreadsheet:

• Format: use this pulldown menu to 
change the formatting of the numbers in 
a cell (rounding, currency, percents, 
etc.).

• Background color: changes the color of 
the selected cells.

• Border: adds a border to the selected 
cells.

• Align: changes the vertical as well as 
horizontal alignment of the selected 
cell’s contents.

• Insert and Delete: add and delete rows 
and columns.

• Merge across: merge several cells into 
one cell.

Sorting and Freezing 
The first row in a Google spreadsheet is a 
header row.  Below the header row is a 
separator bar.  A quick way to sort a col-
umn’s cells is to click on this separator 
bar until a Sort label appears.  By clicking 
on the disclosure triangle you can alter-
nate between ascending and descending 
sort order.

To freeze rows or columns, click on the 
Sort tab, then choose Freeze header 
rows or Freeze columns.

Formulas
To perform calculations using a formula:
1. Select a range of cells.
2. Click on the Formulas tab.
3. Click on one of the formulas on the 

right (Sum, Count, Average, Min, Max, 
etc.)  Click on the more>> link to view 
more advanced formulas supported 
by Google Spreadsheets.

4. The formula will be shown in the same 
cell where the results will be displayed 
once you press Enter 
or Return on your key-
board.
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5. To edit a formula, double-click on the 
cell with the results (the formula will 
be shown in the blue area above the 
column headings), then press Enter or 
Return once you’re done editing it.

Charts
To create a chart: 
1. Enter your data into two rows or col-

umns.
2. Select the cells with data on them.
3. Click on the Chart button in the tool-

bar.
4. Choose a chart type and subtype by 

clicking on one of the buttons.
5. Enter labels for the chart title and the 

horizontal and vertical axis, and 
choose where the legend will be dis-
played.

6. Once the preview shows the chart 
with the options you want, click on 
Save chart.

7. Drag the chart where you want it to 
display in your spreadsheet.

8. To save the chart as an image, click 
on the Chart pulldown menu at the top  
of the chart and choose Save image.  
To edit the chart once it has been cre-
ated, choose Edit chart from this 
menu.  To delete the chart, choose 
Delete chart.  To add the chart to a 
webpage, choose Publish chart, then 
copy the the HTML code and paste it 
into your web page.

Export Data
To export your data so you can use it in 
another program:
1. Choose File > Export.
2. Choose a format from the submenu:
• .csv, .txt, and .html - the current sheet 

will open in a separate window so you 
can copy the data.

• .xls (Excel) - a window will pop up, 
prompting you to save the data as a 
new file. 

Google Presentations
Creating a Presentation
To create a new presentation:
1. Click on New in the file manager’s 

toolbar.
2. Choose Presentation.
3. Choose File > Rename when the new 

presentation opens and enter the 
name you want to use for your pres-
entation.

4. Click on the Save button on the right 
to save your presentation (Google 
saves it at regular intervals as well).

5. To add a new slide, click on the New 
slide button in the toolbar, then 
choose a slide layout by clicking on 
the appropriate thumbnail.

6. The next two buttons in the toolbar 
allow you to duplicate and delete 
slides.

7. The slides in your presentation will be 
listed in a slide sorter on the left, with 
a preview of the slide on the right.  
You can use the Prev and Next but-
tons above the sorter to navigate your 
presentation.  You can rearrange 
slides by dragging and dropping to 
change their order in the slide sorter.

8. To change the look of your slides, 
click on Change theme and choose a 
different theme.

Another way to create a Google Docs 
presentation is by uploading an existing 
PowerPoint file:
1. Click on Upload in the file manager 

toolbar (or choose File > Upload a file 
after you’ve created a new presenta-
tion in Google Docs).

2. Click on Choose File, then locate the 
PowerPoint presentation you want to 
upload on your computer.

3. Click on Upload File.
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If you want to import individual slides 
from an existing PowerPoint presentation:
1. Choose File > Import slides after 

you’ve created a new Google Docs 
presentation.

2. Click on Browse to locate the Power-
Point presentation on your computer.

3. Choose the slides you want to import 
by checking the box next to their slide 
number.

4. Click on Import.

Adding Content
Each slide layout includes one or more 
text placeholders.  You can replace these 
placeholders with your own text by click-
ing on them and entering the text you 
want to appear on the slide.  Once you 
add the text, you can apply any of the 
formatting options available in the toolbar. 

In addition to the placeholder text, you 
can also add:
• Images:  Click on Insert image in the 

toolbar, then on Browse to find the im-
age on your computer and click on Ok.  
You can also drag images from other 
browser windows directly into your 
slides.

• Text Boxes:  Click on Insert text in the 
toolbar, then use the handles to resize 
or reposition the text box.   Click inside 
the box and type in the text you want.

• Shapes: Click on Insert shape and 
choose a callout or arrow to add it to 
your slide. 

Sharing a Presentation
There are three ways you can share a 
presentation (click on the appropriate tab 
on the right side of the window):
• Email: Opens up a new window where 

you can address a message and in-
clude a link to the presentation.  

• Share:  This invites other people so 
they can edit the presentation online.  

The process for sharing a presentation 
is similar to sharing a document or 
spreadsheet.

• Publish:  This option provides you with 
some HTML code you can place on a 
web page to display the presentation 
inside a frame.


 `
Playing the Presentation
To play a presentation, click on the Start 
presentation link on the right side of the 
Google Docs window.  This will open the 
presentation in a new window with navi-
gation controls in the lower left corner of 
the window.  To exit the presentation, 
click on the X in the lower right corner.

Google Docs also allows you to collabo-
rate on a presentation created online.  
When you play a presentation, on the 
right side of the window you will see a 
chat area.  This area can be used to 
share comments about a presentation 
using instant messaging.  Above the chat 
area is a button which allows you to take 
control of the presentation.  When you 
take control, the other people in the ses-
sion cannot advance the slides. 

Printing and Exporting as PDF
To print an open presentation:
1. Choose File > Print to open the Print 

Preview dialog box.
2. Choose the number of slides you want 

to include in each page using the 
Layout pulldown menu.

3. Uncheck the Show background button 
if you want to save ink by only printing 
out the text in your slides.

4. Click on Print at the bottom of the dia-
log box.

There are two ways to save a PDF ver-
sion of an open presentation:
• Choose File > Save as PDF.  This will 

download a PDF version of your pres-
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entation and open it with your default 
program for opening PDFs (usually 
Preview on the Mac, Adobe Acrobat 
Reader on Windows).

• Choose File > Print to bring up the Print 
Preview dialog box, then click on Save 
as PDF at the bottom of the dialog box.

  
Miscellaneous
Google Docs
•  Insert a comment: click on the Insert 

tab and choose Comment. Type your 
comment and press Enter or Return.

• Insert special symbols: click on the In-
sert tab and choose Special character.  
Click on a character to insert it into your 
document.

• Count the number of words: choose File 
> Word count.

• Add a page break: Choose Insert > 
Separator > Page break (a dotted line 
will show you where the new page 
starts).

Google Spreadsheets
• Chat: You can have a text chat with 

everyone who’s working on a docu-
ment.  To start a chat, click on the Dis-
cuss tab.

• Embedding: When you publish a 
spreadsheet, you can choose to embed 
it in a web page so that it automatically 
updates when changes are made in 
Google Docs and Spreadsheets.

To embed a spreadsheet:
1. Click on Publish.
2. Click on More publishing options.
3. Under File format, choose HTML to 

embed in a webpage.
4. Click on Generate URL.
5. Copy and paste the code and it it to 

your web page’s code where you want 
the embedded spreadsheet to appear.

Classroom Ideas
• Book Reports: have two students read 

the same book and then collaborate on 
a final book report using Google Docs.

• Science Experiment: partner with an-
other class (or even another school) 
and run the same experiment.  Com-
pare the data using Google spread-
sheets.

• Story Writing: have students take turns 
writing a chapter of a story.  Use the re-
visions feature to see whose turn it is.

• Visual Essays: assign groups of stu-
dents with the task of creating a visual 
essay about their school or community 
using Google Docs presentations and 
digital images.

• Economics: use Google Docs spread-
sheets to have students track their in-
vestment portfolios as part of a stock 
market game.

• Reflections: use Google Docs as a 
place for students to keep weekly study 
journals where they reflect on their 
work.

             

(http://docs.google.com)
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